Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Hex Kit v1.0.1 Released

Hex Kit v1.0.1 can get got right over here:


  • Export functions work correctly. 'Export' will export the map with everything showing except fog of war; any hidden layers will appear, etc. 'Export Display' will export the map as it appears in display mode. Hidden layers will not be included, fog of war will appear, etc.

  • Maps exported using 'Export Display' are exported in the proper resolution (1:1) and fog of war tiles are not semi opaque.

  • Removed Herobrine.

  • Export no longer hangs, this was caused by layers with nothing on them.

  • Layers with duplicate names no longer cause trouble, but two layers cannot have the same name anymore. Attempting to name two layers with the same name will prevent you from naming the second one.

  • MacOS version now deploys as a DMG file.

  • Fixed multi-select in MacOS.

  • Keybinds are turned off when saving in MacOS, which was causin' some guff.

  • First startup should no longer result in blank canvases.

  • Hex Kit will prompt for saving maps if changes have been made every single time, instead of whenever it feels like it.

  • Hex Kit will no longer freak out if you've moved your tile folders around. Probably shouldn't move them around anyways.

Installation: Override the old files with the new files. Important!: Leave your tiles where they're at, or you're gunna have an empty tile selector! MacOS users; delete the old install and replace with the DMG. All users: If you're tiles are in your Hex Kit folder, leave them there and just replace everything else.

If you notice any hiccups or have problems, be sure to report them here on the forums.


  • Just to keep you apprised of the Itch client still doesn't work with the DMG.

    The Itch client fails to extract anything from the DMG so it just hangs trying to install.

    As before, manually downloading and opening the DMG works fine.

  • edited May 2017

    Itch uninstall log, works fine:

    [2017-05-07 @ 18:19:38.507] [install/archive] wiping directory /Users/aaron/Library/Application Support/itch/apps/Hex Kit
    [2017-05-07 @ 18:19:39.097] [install/archive] cleaning up cache
    [2017-05-07 @ 18:19:39.100] [uninstall] Uninstallation successful
    [2017-05-07 @ 18:19:39.100] [uninstall] Erasing archive /Users/aaron/Library/Application Support/itch/downloads/
    [2017-05-07 @ 18:19:39.104] [uninstall] Imploding cave /Users/aaron/Library/Application Support/itch/apps/Hex Kit
    [2017-05-07 @ 18:19:39.109] [reactors/tasks] uninstall ended, no result

    But installing, not so much:

    [2017-05-07 @ 18:19:42.770] [download-watcher] Starting download...
    [2017-05-07 @ 18:19:43.453] [butler] butler: Downloading 206 MiB
    [2017-05-07 @ 18:19:43.454] [butler] butler: Resuming at 0 B / 206 MiB
    [2017-05-07 @ 18:19:54.108] [butler] butler: < 0 B + 206 MiB copied @ 19 MiB/s
    [2017-05-07 @ 18:19:54.115] [download-watcher] Download ended, err: <none>
    [2017-05-07 @ 18:19:54.117] [reactors/tasks] Download finished, starting install.
    [2017-05-07 @ 18:19:54.123] [install] upgrading from build id undefined => build id undefined
    [2017-05-07 @ 18:19:54.126] [install] installed mtime = NaN, archive mtime = 1494206394000
    [2017-05-07 @ 18:19:54.129] [install/core] retrieving installer type of /Users/aaron/Library/Application Support/itch/downloads/471692.dmg from cache
    [2017-05-07 @ 18:19:54.129] [install/core] invalid installer name stored: undefined - discarding
    [2017-05-07 @ 18:19:54.131] [install/core] sniffed type {"ext":"dmg","mime":"application/x-apple-diskimage"} for /Users/aaron/Library/Application Support/itch/downloads/471692.dmg
    [2017-05-07 @ 18:19:54.135] [install/dmg] Preparing installation of '/Users/aaron/Library/Application Support/itch/downloads/471692.dmg'
    [2017-05-07 @ 18:19:54.179] [install/dmg] Found image undefined
    [2017-05-07 @ 18:19:54.179] [install/dmg] Trying to unlink /Users/aaron/Library/Application Support/itch/downloads/471692.dmg.cdr
    [2017-05-07 @ 18:19:54.196] [install/dmg] Converting archive '/Users/aaron/Library/Application Support/itch/downloads/471692.dmg' to CDR with hdiutil
    [2017-05-07 @ 18:19:54.319] [download-watcher] Cancelling/clearing out last download
    [2017-05-07 @ 18:19:54.516] [install/dmg] Attaching cdr file /Users/aaron/Library/Application Support/itch/downloads/471692.dmg.cdr
    [2017-05-07 @ 18:19:56.085] [install/dmg] hdiutil attach: /dev/disk4                                            /Volumes/Hex Kit
    [2017-05-07 @ 18:19:56.085] [install/dmg] found dev / mountpoint: '/dev/disk4' '/Volumes/Hex Kit'

    And then it just hangs there.

  • Yeah we're still not itch client compatible, I should ammend the changelog to reflect that. That bug was a left field thing for us and we haven't had a chance to get to it. it's next though.

  • Awesome! Good work guys.

  • Thx for looking into it! :)

  • Great! Used the new version to output my GM and Player maps last night!
    Now I can really work on making maps, knowing I can fog of war out details the players are not aware of yet... :)

Sign In or Register to comment.